<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" /><script type="text/javascript">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</script>
	<link rel="pingback" href="https://boston.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="joy the magical clown, west bridgewater news, george hebert, clown retires, lisa hughes" />
<meta name="keywords" content="joy the magical clown, west bridgewater news, george hebert, clown retires, lisa hughes" />
<meta property="fb:pages" content="7446277009" />
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<title>After 60 Years, Joy The Magical Clown Hangs Up His Size 20 Shoes &#8211; CBS Boston</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<meta name="msvalidate.01" content="FDD12CE797EAB78953FDE9ACF7F312A5" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onIframesReady","onFormsReady","onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CBS Boston &raquo; Feed" href="https://boston.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Boston &raquo; Comments Feed" href="https://boston.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Boston &raquo; After 60 Years, Joy The Magical Clown Hangs Up His Size 20 Shoes Comments Feed" href="https://boston.cbslocal.com/2020/02/05/george-herbert-west-bridgewater-joy-magical-clown-retires/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://boston.cbslocal.com/_static/??-eJytUMsOwjAM+yFKhBBDOyC+JW3DqJamVR/a71M6LjvBJE5JnNiyA0tUJkghKVCe5CmD0VlxMMjgxHC1byhneIRQKB1be4CfSOQ12ZUbE3FA+50cuU5OMvhgK7eNToSzk0kJLavUBtkviB9Hre4n9wPlUXCi1GU2iGqp5xLijh+tGtVrQceKncz/d0XcJik9793fTpfhOozjMJ5fjSm+LA==' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://boston.cbslocal.com/_static/??-eJyNy0sKgDAMANELWaPFUlyIZ6kxqJB+IBHx9toLiNvhDVzFYE5KSUF3iiSAixjOGBhEb6YWRRr4YkdCPteaRKCEjYxSLBz0x1sX4jcmlarnOPXOD91onbcPIdY5Hg==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://boston.cbslocal.com/_static/??-eJydkttOwzAMhl+ILIKC2A3iWVLXdKFOHCXuSt8eZwcmGIK1d39i/58Psp2SAY6CUazsMGCx0BZDDI5sorH3sdjA3UgaOSSY4KLrMVso+jMnfNyourN/gXwEGrv6pZ7Jd2gEQyInWBaak8tyg+dn52XHWYDPlMtzQXkMLXZH/0Ea8kUMOHHE/cIxdAoPhGZ/Wd63eKdo26px0Cptdnm2RWbCTfBx+fS68R7la/tVX0HCaM62d5TkYLiyvznAlrm2NKj4OLW0giScTOKi6nfEiksMLg8VfcwHJs4r7uQ/Lu8xT9nLTVNX+0nX9Nfwcv/0vG2aZvvQfAJmxE8C' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://boston.cbslocal.com/_static/??-eJy1kEESwiAMRS8kYnW0K8ezUIg0NYRago63Fzsu7MrWGVeB8P/LJ/reKxtZgEVLCwGStk1SFK0hjWwpu9Lqku4jPc5ItA7I6y6t9FxjN8vRU/bISYfoMpUX40ZzKeq2/SRM0NcMw+NdvgpUQD8YgZ/yjAIVDBsPwws9aagy7yKxX7SYc2YrGDn9IxBQubGkRYmMayHhbd6Git5TbAwtGzEIWoLF372j8yAj4n0siFM4Vvv6UFfVZrfrnnXyCnM='></script>
<link rel='https://api.w.org/' href='https://boston.cbslocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://boston.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://boston.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://cbsloc.al/31ucQvE' />
<link rel="alternate" type="application/json+oembed" href="https://boston.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fboston.cbslocal.com%2F2020%2F02%2F05%2Fgeorge-herbert-west-bridgewater-joy-magical-clown-retires%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://boston.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fboston.cbslocal.com%2F2020%2F02%2F05%2Fgeorge-herbert-west-bridgewater-joy-magical-clown-retires%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="After 60 Years, Joy The Magical Clown Hangs Up His Size 20 Shoes" /><meta property="og:image" content="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?w=1024" /><meta property="og:image:secure_url" content="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?w=1024" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="576" /><meta property="og:description" content="A West Bridgewater man is hanging up his size 20 clown shoes after 60 years of making people laugh." /><meta property="og:type" content="article" /><meta property="og:url" content="https://boston.cbslocal.com/2020/02/05/george-herbert-west-bridgewater-joy-magical-clown-retires/" /><meta property="article:published_time" content="2020-02-05T18:30:37+00:00" /><meta property="article:suggested-social-copy" content="A West Bridgewater man is hanging up his size 20 clown shoes after 60 years of making people laugh." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="article:publisher" content="http://www.facebook.com/CBSBoston" /><meta property="article:author" content="http://www.facebook.com/CBSBoston" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?w=1024"><meta name="twitter:title" content="After 60 Years, Joy The Magical Clown Hangs Up His Size 20 Shoes"/><meta name="twitter:description" content="A West Bridgewater man is hanging up his size 20 clown shoes after 60 years of making people laugh."/><meta name="twitter:site" content="/wbz"/>
<link rel="canonical" href="https://boston.cbslocal.com/2020/02/05/george-herbert-west-bridgewater-joy-magical-clown-retires/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
						<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="amphtml" href="https://boston.cbslocal.com/2020/02/05/george-herbert-west-bridgewater-joy-magical-clown-retires/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/boston.cbslocal.com","url":"https:\/\/boston.cbslocal.com","name":"CBS Boston","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/boston.cbslocal.com\/wp-content\/uploads\/sites\/3859903\/2018\/02\/4_boston_wbz.png?w=220"}},"url":"https:\/\/boston.cbslocal.com\/2020\/02\/05\/george-herbert-west-bridgewater-joy-magical-clown-retires\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/boston.cbslocal.com\/2020\/02\/05\/george-herbert-west-bridgewater-joy-magical-clown-retires\/"},"headline":"After 60 Years, Joy The Magical Clown Hangs Up His Size 20 Shoes","description":"A West Bridgewater man is hanging up his size 20 clown shoes after 60 years of making people laugh.","image":"https:\/\/boston.cbslocal.com\/wp-content\/uploads\/sites\/3859903\/2020\/02\/Clown2.jpg?w=200","keywords":["Boston News","News","Syndicated Local","Lisa Hughes","West Bridgewater News","news","After 60 Years, Joy The Magical Clown Hangs Up His Size 20 Shoes"],"datePublished":"2020-02-05T18:30:37+00:00","dateModified":"2020-02-05T18:30:37+00:00","author":{"@type":"Person","name":"Lisa Hughes"},"video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"After 60 Years, Joy The Magical Clown Retires","description":"But the man behind the magic has something special planned for his next act.","thumbnailUrl":"https:\/\/xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net\/captures\/48E\/815\/48E8159CB34F469F805AD041021BF5A7.jpg?Expires=1675560328&KeyName=mcpkey1&Signature=Ldh9oqXqJU61XO3OOB527yDhJWA","uploadDate":"2020-02-05","duration":"T2M8S","contentUrl":"https:\/\/boston.cbslocal.com\/video\/4435128-after-60-years-joy-the-magical-clown-retires\/","embedUrl":"https:\/\/boston.cbslocal.com\/video\/4435128-after-60-years-joy-the-magical-clown-retires\/"}}</script>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="After 60 Years, Joy The Magical Clown Hangs Up His Size 20 Shoes" />
<meta property="og:url" content="https://boston.cbslocal.com/2020/02/05/george-herbert-west-bridgewater-joy-magical-clown-retires/" />
<meta property="og:description" content="A West Bridgewater man is hanging up his size 20 clown shoes after 60 years of making people laugh." />
<meta property="article:published_time" content="2020-02-05T23:30:37+00:00" />
<meta property="article:modified_time" content="2020-02-05T23:30:37+00:00" />
<meta property="og:site_name" content="CBS Boston" />
<meta property="og:image" content="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg" />
<meta property="og:image:width" content="420" />
<meta property="og:image:height" content="236" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="After 60 Years, Joy The Magical Clown Hangs Up His Size 20 Shoes" />
<meta name="twitter:image" content="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.BOSTON","news",["after60yearsjoythemagicalclownhangsuphissize20shoes","post","article","bostonnews","news","syndicatedlocal","lisahughes","westbridgewaternews","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("1");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-2438645-63" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-2438645-63" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"boston-news;news;syndicated-local;","dimension2":"article"});gtag("config","UA-2438645-63");</script>

<link rel="icon" href="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2019/07/cropped-boston-favicon-5121.png?w=32" sizes="32x32" />
<link rel="icon" href="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2019/07/cropped-boston-favicon-5121.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2019/07/cropped-boston-favicon-5121.png?w=180" />
<meta name="msapplication-TileImage" content="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2019/07/cropped-boston-favicon-5121.png?w=270" />
		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 10px;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="A West Bridgewater man is hanging up his size 20 clown shoes after 60 years of making people laugh." />
<script>//<![CDATA[
//]]></script>

</head>

<body class="post-template-default single single-post postid-1041087 single-format-standard desktop-display-type  and-temp-wide w-breaking-news"><div id="wrapper" class="body-wrapper">

<div id="breaking-news"><div class="wrapper"><a href="https://boston.cbslocal.com/2020/02/05/boston-snow-new-england-weather-february-6-storm-wbz/" title="WEATHER ALERT:" class="cbs-thumbnail-link" ><div class="title-wrapper"><strong class="title">WEATHER ALERT:</strong><em class="description">Snow, Rain, Sleet, Ice Mix Will Make Mess Of Thursday Morning Commute</em></div></a></div></div><div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://boston.cbslocal.com" id="header-logo"><img src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2018/02/4_boston_wbz.png?w=220" alt="CBS Boston" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://boston.cbslocal.com/category/sports/">Sports</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://boston.cbslocal.com/category/sports/patriots/" title="Patriots" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Patriots</strong></div></a><a href="https://boston.cbslocal.com/category/sports/red-sox/" title="Red Sox" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Red Sox</strong></div></a><a href="https://boston.cbslocal.com/category/sports/bruins/" title="Bruins" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Bruins</strong></div></a><a href="https://boston.cbslocal.com/category/sports/celtics/" title="Celtics" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Celtics</strong></div></a><a href="https://boston.cbslocal.com/live-streaming-video-from-cbs-sports/" title="CBS Sports HQ Live" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">CBS Sports HQ Live</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://boston.cbslocal.com/video/">Video</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/live/" title="CBSN Boston" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">CBSN Boston</strong></div></a><a href="https://boston.cbslocal.com/cbsn-live-streaming-video-from-cbs-news/" title="CBSN National" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">CBSN National</strong></div></a><a href="https://boston.cbslocal.com/live-streaming-video-from-cbs-sports/" title="CBS Sports HQ Live" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">CBS Sports HQ Live</strong></div></a><a href="https://boston.cbslocal.com/video/category/news/" title="All News Video" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">All News Video</strong></div></a><a href="https://boston.cbslocal.com/video/category/sports/" title="All Sports Video" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">All Sports Video</strong></div></a><a href="https://boston.cbslocal.com/video/category/news-weather-forecast/" title="Weather Forecast" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Weather Forecast</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="https://boston.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">News Sections</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/category/news/" title="All News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">All News</strong><em class="description">Local Boston News From WBZ Channel 4 CBS</em></div></a><a href="https://boston.cbslocal.com/category/news/local/" title="Boston News" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Boston News</strong></div></a><a href="https://boston.cbslocal.com/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://boston.cbslocal.com/category/politics/" title="Politics" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Politics</strong></div></a><a href="https://boston.cbslocal.com/category/news/business/" title="Business" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Business</strong></div></a><a href="https://boston.cbslocal.com/category/news/education/" title="Education" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Education</strong></div></a><a href="https://boston.cbslocal.com/category/news/consumer/" title="Consumer" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Consumer</strong></div></a><a href="https://boston.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://boston.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="https://boston.cbslocal.com/category/cbs-boston-blogs/blogs/" title="Blogs" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">Blogs</strong><em class="description">CBS Boston Blogs</em></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Exclusively WBZ</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/category/i-team/" title="I-Team" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">I-Team</strong></div></a><a href="https://boston.cbslocal.com/call-for-action/" title="Call 4 Action" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Call 4 Action</strong></div></a><a href="https://boston.cbslocal.com/category/wednesdays-child/" title="Wednesday&#039;s Child" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Wednesday&#039;s Child</strong></div></a><a href="https://boston.cbslocal.com/podcasts/studio-bz/" title="Studio BZ Podcast" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Studio BZ Podcast</strong></div></a><a href="https://boston.cbslocal.com/tag/it-happens-here/" title="It Happens Here" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">It Happens Here</strong></div></a><a href="https://boston.cbslocal.com/tag/boston-next/" title="Boston Next" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Boston Next</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Headlines</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/2020/02/05/dna-evidence-clears-ronnie-qualls/" title="DNA Evidence Clears Man Convicted In Double Murder 30 Years Ago, Prosecutors Say" class="cbs-thumbnail-link item-1580951898 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/RonnieQualls.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">DNA Evidence Clears Man Convicted In Double Murder 30 Years Ago, Prosecutors Say</strong><em class="description">Prosecutors say new DNA evidence clears a man convicted of a double murder in Roxbury nearly 30 years ago.</em></div></a><a href="https://boston.cbslocal.com/2020/02/05/firefighters-battle-large-fire-on-east-7th-street-in-south-boston/" title="Firefighters Battle Large Fire On East 7th Street In South Boston" class="cbs-thumbnail-link item-1580949331 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/fire2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Firefighters Battle Large Fire On East 7th Street In South Boston</strong><em class="description">A fire broke out at a duplex under construction in South Boston Wednesday. </em></div></a><a href="https://boston.cbslocal.com/2020/02/05/red-sox-fans-react-mookie-betts-david-price-trade/" title="Red Sox Fans Question Mookie Betts Trade But Say They Won&#039;t Shed Tears Over David Price" class="cbs-thumbnail-link item-1580948639 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2018/12/gettyimages-1054042234.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Red Sox Fans Question Mookie Betts Trade But Say They Won&#039;t Shed Tears Over David Price</strong><em class="description">Fenway Park was not a happy place Wednesday as Red Sox fans weighed in on the big trade that sent Mookie Betts and David Price to the Dodgers.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="https://boston.cbslocal.com/category/weather/" title="Weather" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Links</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/closings/" title="School Closings" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">School Closings</strong></div></a><a href="https://boston.cbslocal.com/category/weather/#section-weather-map-3" title="Interactive Radar" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Interactive Radar</strong></div></a><a href="https://boston.cbslocal.com/category/beyond-the-forecast/" title="Weather Blog" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Weather Blog</strong></div></a><a href="http://apps.cbslocal.com/weather/boston/" title="Weather App" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Weather App</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Video Forecast</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/video/4435124-wbz-evening-forecast-for-feb-5/" title="WBZ Evening Forecast For Feb. 5" class="cbs-thumbnail-link item-1580944910 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/295/4C8/2954C81284CE47368A384C7FD99FA932.jpg?Expires=1675560250&#038;KeyName=mcpkey1&#038;Signature=R5Hf7t4Jg8TeKDpz7-rnFPmeuw4"></span></div><div class="title-wrapper"><strong class="title">WBZ Evening Forecast For Feb. 5</strong><em class="description">Eric Fisher has an updated weather forecast.</em></div><time datetime="2020-02-05T23:21:50+00:00" title="February 5, 2020 at 6:21 pm">2 hours ago</time></a><a href="https://boston.cbslocal.com/video/4434881-wbz-evening-forecast-for-february-5-2020/" title="WBZ evening forecast for February 5, 2020" class="cbs-thumbnail-link item-1580936209 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/7EA/7AA/7EA7AAEF5189438AB8CE78462464493F.jpg?Expires=1675560250&#038;KeyName=mcpkey1&#038;Signature=dGf7roToZAF-iP0hi3M-GrIQO7w"></span></div><div class="title-wrapper"><strong class="title">WBZ evening forecast for February 5, 2020</strong><em class="description">Eric Fisher has your latest WBZ-TV forecast</em></div><time datetime="2020-02-05T20:56:49+00:00" title="February 5, 2020 at 3:56 pm">4 hours ago</time></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Blog</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/2020/02/05/boston-snow-new-england-weather-february-6-storm-wbz/" title="Multi-Day Storm To Bring Snow, Sleet And Rain To New England, Impacting Several Commutes" class="cbs-thumbnail-link item-1580936466 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/bloga2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Multi-Day Storm To Bring Snow, Sleet And Rain To New England, Impacting Several Commutes</strong><em class="description">There are several layers to a storm that will feature a combination of snow, sleet, and rain over the next several days.</em></div></a><a href="https://boston.cbslocal.com/2020/02/04/messy-thursday-snow-storm-rain-new-england/" title="Snow, Rain, Sleet, Ice Mix Will Make Mess Of Thursday Morning Commute" class="cbs-thumbnail-link item-1580874707 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/amcommute.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Snow, Rain, Sleet, Ice Mix Will Make Mess Of Thursday Morning Commute</strong><em class="description">This storm will be a long one, featuring several rounds of varying precipitation.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link w-submenu"><a href="https://boston.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://boston.cbslocal.com/category/sports/">All Sports</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://boston.cbslocal.com/category/sports/patriots/" title="Patriots" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Patriots</strong></div></a><a href="https://boston.cbslocal.com/category/sports/red-sox/" title="Red Sox" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Red Sox</strong></div></a><a href="https://boston.cbslocal.com/category/sports/bruins/" title="Bruins" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Bruins</strong></div></a><a href="https://boston.cbslocal.com/category/sports/celtics/" title="Celtics" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Celtics</strong></div></a><a href="https://boston.cbslocal.com/live-streaming-video-from-cbs-sports/" title="CBS Sports HQ Live" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">CBS Sports HQ Live</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-5 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Headlines</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/2020/02/05/tom-brady-impromptu-health-seminar-instagram-silent-which-team-play-for/" title="Tom Brady Holds Impromptu Health Seminar On Instagram, Goes Silent When Asked Which Team He&#039;ll Play For" class="cbs-thumbnail-link item-1580939442 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/GettyImages-1203635681.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Tom Brady Holds Impromptu Health Seminar On Instagram, Goes Silent When Asked Which Team He&#039;ll Play For</strong><em class="description">Tom Brady showed that to be the case on Wednesday afternoon, when he had some free time while riding in a back seat through the streets of New York City. Brady decided to do a rapid question-and-answer session for everyone who sent in some questions a day earlier.</em></div></a><a href="https://boston.cbslocal.com/2020/02/05/if-evan-turner-gets-bought-out-celtics-will-reportedly-be-interested-in-reunion/" title="If Evan Turner Gets Bought Out, Celtics Will Reportedly Be Interested In Reunion" class="cbs-thumbnail-link item-1580929584 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/evan-turner.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">If Evan Turner Gets Bought Out, Celtics Will Reportedly Be Interested In Reunion</strong><em class="description">If the Boston Celtics don&#039;t make any deals ahead of Thursday&#039;s NBA trade deadline, they&#039;re expected to scour the buyout market for some veteran help. That help may come from an old friend.</em></div></a><a href="https://boston.cbslocal.com/2020/02/05/jim-rice-mookie-betts-wanted-to-stay-with-red-sox-business-deal/" title="Jim Rice: Mookie Betts &#039;Wanted To Stay&#039; With Red Sox, But Has To Accept &#039;Business Deal&#039;" class="cbs-thumbnail-link item-1580927556 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/GettyImages-1172612230.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Jim Rice: Mookie Betts &#039;Wanted To Stay&#039; With Red Sox, But Has To Accept &#039;Business Deal&#039;</strong><em class="description">Somewhere along the way, a story developed where Mookie Betts wanting to leave Boston. According to Hall of Famer Jim Rice, that&#039;s not true.</em></div></a><a href="https://boston.cbslocal.com/2020/02/05/red-sox-jon-lester-decision-eventually-mookie-betts-trade/" title="How Red Sox&#039; Jon Lester Decision Eventually Led To Mookie Betts Trade" class="cbs-thumbnail-link item-1580925165 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Untitled-1-4.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How Red Sox&#039; Jon Lester Decision Eventually Led To Mookie Betts Trade</strong><em class="description">The Red Sox deemed Jon Lester to be expendable in 2014. And that is where the road to trading Mookie Betts began. Let&#039;s explore.</em></div></a><a href="https://boston.cbslocal.com/2020/02/05/kemba-walker-marcus-smart-out-again-wednesday-night-when-celtics-host-magic/" title="Kemba Walker, Marcus Smart Out Again Wednesday Night When Celtics Host Magic" class="cbs-thumbnail-link item-1580923707 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/smart-walker.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Kemba Walker, Marcus Smart Out Again Wednesday Night When Celtics Host Magic</strong><em class="description">At some point this season, it may be easier to just write which players will be active for the Boston Celtics. Once again, the C&#039;s will be pretty shorthanded on Wednesday night.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-4 w-link w-submenu"><a href="https://boston.cbslocal.com/video/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://boston.cbslocal.com/video/">All Videos</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/live/" title="CBSN Boston" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">CBSN Boston</strong></div></a><a href="https://boston.cbslocal.com/cbsn-live-streaming-video-from-cbs-news/" title="CBSN National" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">CBSN National</strong></div></a><a href="https://boston.cbslocal.com/live-streaming-video-from-cbs-sports/" title="CBS Sports HQ Live" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">CBS Sports HQ Live</strong></div></a><a href="https://boston.cbslocal.com/video/category/news/" title="All News Video" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">All News Video</strong></div></a><a href="https://boston.cbslocal.com/video/category/sports/" title="All Sports Video" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">All Sports Video</strong></div></a><a href="https://boston.cbslocal.com/video/category/news-weather-forecast/" title="Weather Forecast" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Weather Forecast</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-5 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">On Demand Video</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/video/4435293-prosecutors-dna-evidence-clears-man-convicted-of-1992-murders/" title="Prosecutors: DNA Evidence Clears Man Convicted Of 1992 Murders" class="cbs-thumbnail-link item-1580951760 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/F78/BB6/F78BB66B62C242E38FE196C8E9E6A976.jpg?Expires=1675560188&#038;KeyName=mcpkey1&#038;Signature=fqnS4ATfSx4y5jmAnNu2F6I9zUE"></span></div><div class="title-wrapper"><strong class="title">Prosecutors: DNA Evidence Clears Man Convicted Of 1992 Murders</strong><em class="description">Prosecutors have asked for the release of Ronnie Qualls</em></div><time datetime="2020-02-06T01:16:00+00:00" title="February 5, 2020 at 8:16 pm">9 minutes ago</time></a><a href="https://boston.cbslocal.com/video/4435270-firefighters-battle-large-fire-on-east-7th-street-in-south-boston/" title="Firefighters Battle Large Fire On East 7th Street In South Boston" class="cbs-thumbnail-link item-1580951168 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/8F7/EDD/8F7EDD5DCD0240E0B86E6014DCCA6713.jpg?Expires=1675560188&#038;KeyName=mcpkey1&#038;Signature=shJO4YNZuaBIFFgAFSeiTCNJ2gE"></span></div><div class="title-wrapper"><strong class="title">Firefighters Battle Large Fire On East 7th Street In South Boston</strong><em class="description">Two firefighters sustained minor injuries while battling the blaze.</em></div><time datetime="2020-02-06T01:06:08+00:00" title="February 5, 2020 at 8:06 pm">19 minutes ago</time></a><a href="https://boston.cbslocal.com/video/4435154-wbz-news-update-for-february-5-2020/" title="WBZ News Update For February 5, 2020" class="cbs-thumbnail-link item-1580946144 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/CBC/A3E/CBCA3E74EE1B431FB06B242C0DA32267.jpg?Expires=1675560188&#038;KeyName=mcpkey1&#038;Signature=CHFL30i92VLdnw0OxZqGzqVPNgI"></span></div><div class="title-wrapper"><strong class="title">WBZ News Update For February 5, 2020</strong><em class="description">Senate acquits President Trump; convicted rapist released on medical parole; icy, messy commute Thursday morning.</em></div><time datetime="2020-02-05T23:42:24+00:00" title="February 5, 2020 at 6:42 pm">2 hours ago</time></a><a href="https://boston.cbslocal.com/video/4435135-worcester-diner-will-be-able-to-keep-harley-davidson-mural/" title="Worcester Diner Will Be Able To Keep Harley-Davidson Mural" class="cbs-thumbnail-link item-1580945264 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/702/E75/702E75C18B7C4C898800831D13C3320D.jpg?Expires=1675560188&#038;KeyName=mcpkey1&#038;Signature=Kgm9NwDmTdQ2-kSe3cRHqp1XoTY"></span></div><div class="title-wrapper"><strong class="title">Worcester Diner Will Be Able To Keep Harley-Davidson Mural</strong><em class="description">The Miss Worcester Diner will be able to keep its hand-painted mural featuring the Harley-Davidson logo.</em></div><time datetime="2020-02-05T23:27:44+00:00" title="February 5, 2020 at 6:27 pm">2 hours ago</time></a><a href="https://boston.cbslocal.com/video/4435128-after-60-years-joy-the-magical-clown-retires/" title="After 60 Years, Joy The Magical Clown Retires" class="cbs-thumbnail-link item-1580945029 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/48E/815/48E8159CB34F469F805AD041021BF5A7.jpg?Expires=1675560188&#038;KeyName=mcpkey1&#038;Signature=rKLR15PWKvOGVi9ykZCFw_mgEFw"></span></div><div class="title-wrapper"><strong class="title">After 60 Years, Joy The Magical Clown Retires</strong><em class="description">But the man behind the magic has something special planned for his next act.</em></div><time datetime="2020-02-05T23:23:49+00:00" title="February 5, 2020 at 6:23 pm">2 hours ago</time></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="https://boston.cbslocal.com/category/bostons-best/" title="Boston’s Best" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Boston’s Best</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://boston.cbslocal.com/category/bostons-best/">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/2020/01/30/weekend-events-rooftop-igloos-curling-hasty-pudding-parade/" title="Weekend To Do List: Igloos, Curling And A Hasty Pudding Parade" class="cbs-thumbnail-link item-1580411021 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/01/igloo.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weekend To Do List: Igloos, Curling And A Hasty Pudding Parade</strong><em class="description">Grab a cocktail in an igloo. Watch the Hasty Pudding parade in person. Test your hand at curling. Those are items on our weekend To Do List.</em></div></a><a href="https://boston.cbslocal.com/2020/01/24/boston-events-wine-food-festival-rv-camping-show-pmc-winter-cycle/" title="Weekend To Do List: Wine &amp; Food Festival; Camping Show; PMC Winter Cycle" class="cbs-thumbnail-link item-1579856412 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2017/08/wine2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weekend To Do List: Wine &amp; Food Festival; Camping Show; PMC Winter Cycle</strong><em class="description">Hunker down in the winter weather with a delicious dinner expertly paired with wine. That&#039;s just one item on our Weekend To Do List.</em></div></a><a href="https://boston.cbslocal.com/2020/01/21/south-boston-restaurant-fox-the-knife-national-award/" title="Fox And The Knife In South Boston Named Top New Restaurant In America" class="cbs-thumbnail-link item-1579647740 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/01/fox.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Fox And The Knife In South Boston Named Top New Restaurant In America</strong><em class="description">Fox &amp; The Knife, an Italian restaurant in South Boston, has won numerous awards since it opened in February 2019.</em></div></a><a href="https://boston.cbslocal.com/2020/01/17/harry-potter-pop-up-patriot-place-alice-in-the-village/" title="Harry Potter Winter Pop-Up Now Open At Patriot Place" class="cbs-thumbnail-link item-1579288913 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/01/harrypotter2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Harry Potter Winter Pop-Up Now Open At Patriot Place</strong><em class="description">A Harry Potter pop-up is now open at Patriot Place through the winter. Located at Alice in the Village tea house, the pop-up allows guests to experience the magic of the popular books and movies.</em></div></a><a href="https://boston.cbslocal.com/2020/01/16/boston-weekend-events-auto-show-celtic-music-festival-mfa/" title="Weekend To Do List: Auto Show, Music Festival, MFA For Free" class="cbs-thumbnail-link item-1579212539 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/01/2017autoshow.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weekend To Do List: Auto Show, Music Festival, MFA For Free</strong><em class="description">It’s a three day weekend for many people this weekend, and we have some family fun and cultural enrichment on our To Do List.</em></div></a><a href="https://boston.cbslocal.com/2020/01/14/king-tut-treasures-of-the-golden-pharaoh-museum-of-science-mayor-marty-walsh-boston-june/" title="King Tut Exhibition Coming To Boston In June" class="cbs-thumbnail-link item-1579043891 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/01/kingtut1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">King Tut Exhibition Coming To Boston In June</strong><em class="description">The KING TUT: Treasures of the Golden Pharaoh is coming to Boston this summer. </em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-6 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">More</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://boston.cbslocal.com/learn-about-us/">Station Info</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/station/wbz-tv/" title="WBZ-TV" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">WBZ-TV</strong></div></a><a href="https://boston.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://boston.cbslocal.com/station/wbz-tv/" title="WBZ-TV Team" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">WBZ-TV Team</strong></div></a><a href="https://boston.cbslocal.com/station/wbz-tv/" title="Jobs &amp; Internships" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Jobs &amp; Internships</strong></div></a><a href="https://boston.cbslocal.com/category/contests-and-promotions/" title="Contests" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Contests</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Connect</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/contact/" title="Contact WBZ-TV" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Contact WBZ-TV</strong></div></a><a href="https://boston.cbslocal.com/station/wbz-tv/" title="Social Media" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Social Media</strong></div></a><a href="http://apps.cbslocal.com/" title="CBS Local App" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">CBS Local App</strong></div></a><a href="http://apps.cbslocal.com/weather/boston/" title="Weather App" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Weather App</strong></div></a><a href="https://boston.cbslocal.com/callforaction/" title="Call For Action" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Call For Action</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/category/podcasts/" title="Podcasts" class="cbs-thumbnail-link item-1518816596" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2018/02/podcast.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Podcasts</strong></div></a><a href="http://boston.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-1484232790" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2014/06/airplane_-_thinsktock3.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Travel</strong></div></a><a href="http://boston.cbslocal.com/category/only-cbs/" title="CBS Entertainment" class="cbs-thumbnail-link item-1484232704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2017/01/onlycbs.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Entertainment</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	<a id="live" class="v2" href="https://boston.cbslocal.com/live/" data-source_url="https://feeds-cbsn.cbsnews.com/2.0/rundown/?partner=cbsnsite&#038;edition=CBSN-BOS"><span class="button"><strong>CBSN Boston</strong><em>Watch Now</em></span></a>
	<a href="http://boston.cbslocal.com/category/weather/" id="info-weather"><div id="weather-widget-sticker" class="embed-item embed-weather weather-widget-wrap" ><div class="wrapper">
<wx-widget type="current-conditions" latitude="42.360082" longitude="-71.058880" header="false"></wx-widget>
</div></div></a>
	<div id="info-search"><form action="https://boston.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">After 60 Years, Joy The Magical Clown Hangs Up His Size 20 Shoes</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><span class="post-personality">By <a href="https://boston.cbslocal.com/personality/lisa-hughes">Lisa Hughes</a></span><time class="post-date">February 5, 2020 at 6:30 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://boston.cbslocal.com/tag/lisa-hughes/">Lisa Hughes</a>, <a href="https://boston.cbslocal.com/tag/west-bridgewater-news/">West Bridgewater News</a></div></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div id='p0'></div><script type="text/plain" class="optanon-category-4" async data-anvp='{&quot;mcp&quot;:&quot;cbs&quot;,&quot;width&quot;:&quot;100%&quot;,&quot;height&quot;:&quot;100%&quot;,&quot;video&quot;:&quot;4435128&quot;,&quot;autoplay&quot;:true,&quot;titleVisible&quot;:false,&quot;accessKey&quot;:&quot;DVzl9QRzox3ZZsP9bNu5Li3X7obQOnqP&quot;,&quot;accessControl&quot;:{&quot;preview&quot;:false},&quot;pInstance&quot;:&quot;p0&quot;,&quot;plugins&quot;:{&quot;heartbeat&quot;:{&quot;account&quot;:&quot;cbslocal-global-unified&quot;,&quot;publisherId&quot;:&quot;cbslocal&quot;,&quot;jobId&quot;:&quot;sc_va&quot;,&quot;marketingCloudId&quot;:&quot;823BA0335567497F7F000101@AdobeOrg&quot;,&quot;trackingServer&quot;:&quot;cbsdigitalmedia.hb.omtrdc.net&quot;,&quot;customTrackingServer&quot;:&quot;cbsdigitalmedia.d1.sc.omtrdc.net&quot;,&quot;chapterTracking&quot;:false,&quot;version&quot;:&quot;1.5&quot;},&quot;comscore&quot;:{&quot;clientId&quot;:&quot;3000023&quot;,&quot;c3&quot;:&quot;Boston.cbslocal.com&quot;},&quot;dfp&quot;:{&quot;clientSide&quot;:{&quot;adTagUrl&quot;:&quot;http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&amp;iu=\/4128\/CBS.BOSTON&amp;ciu_szs&amp;impl=s&amp;gdfp_req=1&amp;env=vp&amp;output=xml_vast2&amp;unviewed_position_start=1&amp;url=[referrer_url]&amp;description_url=[description_url]&amp;correlator=[timestamp]&quot;,&quot;keyValues&quot;:{&quot;categories&quot;:&quot;[[CATEGORIES]]&quot;,&quot;program&quot;:&quot;[[PROGRAM_NAME]]&quot;,&quot;siteSection&quot;:&quot;featured&quot;}}}},&quot;shareLink&quot;:&quot;https:\/\/cbsloc.al\/31ucQvE&quot;,&quot;video-type&quot;:&quot;featured&quot;,&quot;token&quot;:&quot;default&quot;,&quot;expectPreroll&quot;:true,&quot;expectPrerollTimeout&quot;:5,&quot;recom&quot;:true,&quot;maxRecomPages&quot;:3}' src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js'></script></div></section>
<div id="ott-promotion-block" class="embed-item embed-ottplayer" ><div class="wrapper">
<span class="adhesive-wrapper"><div class="logo-container"><a href="https://boston.cbslocal.com/live/cbsn-boston/"><img src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2019/09/30h-BOS-white-horizontal.png?w=408"/></a></div></span><div class="dvr-container"><div class="dvr-wrapper embed-item embed-slider w-action-manual" data-up_url="https://feeds-cbsn.cbsnews.com/2.0/rundown/?partner=cbsnsite&#038;edition=CBSN-BOS" data-channel_slug="cbsn-boston" data-w-live="true" data-dvr-live-thumb_url="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2019/09/60h-BOS-white-stacked.png?w=161&#038;h=60&#038;crop=1"></div></div><script>jQuery(function($){jQuery(window).load(function(){cbs_embed_ottplayer.update_dvr("#ott-promotion-block .dvr-container .dvr-wrapper");setInterval(function(){cbs_embed_ottplayer.update_dvr("#ott-promotion-block .dvr-container .dvr-wrapper");},30000);});});</script>
</div></div><div class="main-story-wrapper"><p><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd"><br />
<html><body></p>
<p class="x_MsoNormal">WEST BRIDGEWATER (CBS) &#8211; A West Bridgewater man is hanging up his size 20 clown shoes after 60 years of making people laugh. And for Joy the Magical Clown, it&#8217;s been a great run.</p>
<p class="x_MsoNormal">George Hebert got the bug in high school and it grew from there. &#8220;The kids all called me the class clown,&#8221; he said. So, <a href="https://www.facebook.com/JoyTheMagicalClown/" target="_blank" rel="nofollow">Joy the Magical Clown</a> was born.</p>
<div id="attachment_1041091" style="width: 430px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-1041091" class="size-medium wp-image-1041091 jetpack-lazy-image" src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?w=420" alt width="420" height="236" data-lazy-srcset="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg 1024w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=200,113 200w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=420,236 420w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=768,432 768w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=620,349 620w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=640,360 640w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=310,174 310w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=320,180 320w" data-lazy-sizes="(max-width: 420px) 100vw, 420px" data-lazy-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?w=420&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img aria-describedby="caption-attachment-1041091" class="size-medium wp-image-1041091" src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?w=420" alt="" width="420" height="236" srcset="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg 1024w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=200,113 200w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=420,236 420w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=768,432 768w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=620,349 620w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=640,360 640w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=310,174 310w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown1.jpg?resize=320,180 320w" sizes="(max-width: 420px) 100vw, 420px" /></noscript><p id="caption-attachment-1041091" class="wp-caption-text">George Hebert, of West Bridgewater, said the secret is to &#8220;always leave them laughing.&#8221;</p></div>
<p class="x_MsoNormal">&#8220;Once you get the greasepaint in your blood system, it&#8217;s hard to get rid of it.&#8221;&nbsp; It&#8217;s been a 60-year career filled with balloon animals, magic tricks and a whole lot of joy. &#8220;I loved the reaction from the kids, and it gave me the opportunity to bring happiness to people, and that&#8217;s what my whole life is based on.&#8221;</p>
<p class="x_MsoNormal">There have been thousands of shows, from his very first. &#8220;For the Grossman&#8217;s Lumber Company, and Rex Trailer was the featured act,&#8221; he remembered.</p>
<p class="x_MsoNormal">With his big red smile and even bigger personality, Joy the clown lived up to his name. George&#8217;s specialty trick is a classic &#8211; making a coin appear from behind your ear.&nbsp; &#8220;Sometimes I&#8217;ll be walking along and people will say, I know you, you&#8217;re the quarter guy!&#8221;</p>
<div id="attachment_1041092" style="width: 430px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-1041092" class="size-medium wp-image-1041092 jetpack-lazy-image" src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?w=420" alt width="420" height="236" data-lazy-srcset="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg 1024w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=200,113 200w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=420,236 420w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=768,432 768w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=620,349 620w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=640,360 640w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=310,174 310w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=320,180 320w" data-lazy-sizes="(max-width: 420px) 100vw, 420px" data-lazy-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?w=420&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img aria-describedby="caption-attachment-1041092" class="size-medium wp-image-1041092" src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?w=420" alt="" width="420" height="236" srcset="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg 1024w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=200,113 200w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=420,236 420w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=768,432 768w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=620,349 620w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=640,360 640w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=310,174 310w, https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/Clown2.jpg?resize=320,180 320w" sizes="(max-width: 420px) 100vw, 420px" /></noscript><p id="caption-attachment-1041092" class="wp-caption-text">Joy the Magical Clown entertained children for 60 years. (WBZ-TV)</p></div>
<p class="x_MsoNormal">With arthritis cramping his hands, he can&#8217;t do the tricks like he used to, so it&#8217;s time to put the greasepaint away. &#8220;The rest of my clowning will be passing on the trade to people who really want to learn.&#8221;&nbsp; But he&#8217;s still making others happy by running a service called <a href="https://www.facebook.com/ineedaride/" target="_blank" rel="nofollow">I Need A Ride</a>, giving free lifts to people receiving cancer treatments, always with joy.</p>
<p class="x_MsoNormal">&#8220;So many experiences, so much fun, and so many friends.&#8221;</p>
<p><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"103fa8ca15","applicationID":"144794115","transactionName":"ZwdaZBdUX0VTVEBRC15NeVMRXF5YHV5aXAFI","queueTime":0,"applicationTime":300,"atts":"S0BNEl9OTBoQVhYCH00f","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html></p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/31ucQvE"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/31ucQvE"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/31ucQvE"></a></span>
			</div>
		
			</div>
</div></div></div><div id="personality-credits-container" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>Lisa </span> Hughes</h4></header><div class="block-content-wrapper and-list layout-catalog aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" id="personality-credits" data-social-links="{&quot;twitter_url&quot;:&quot;http:\/\/twitter.com\/lisawbz&quot;}" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2017/07/hughes628.jpg?w=628&#038;h=352&#038;crop=1"></span></div><div class="title-wrapper"><em class="description">Award-winning journalist Lisa Hughes is a news anchor for WBZ-TV News weekdays at 5PM, 6PM and 11PM.</em><a href="https://boston.cbslocal.com/personality/lisa-hughes/" id="more-from-personality"><span>More from</span> <strong>Lisa Hughes</strong></a></div></div></div>
</div></div><a href="#" id="enable-comments-button" class="generic-button-v1" onclick="document.getElementById('story-comments').style.display=(document.getElementById('story-comments').style.display==='block')?'none':'block';return false;">Comments</a>
	<style>
	#comments .comments-title,
	#comments #respond #reply-title {
		color: black;
		font-size: 16px;
		font-weight: normal;
		margin-bottom: 20px;
	}
	#comments a:hover {
		text-decoration: underline;
	}
	#comments .comment-list,
	#comments .comment-list .children {
		list-style: none;
		margin: 0;
	}
		#comments .comment-list .comment {
			border-top: 1px solid #eaeaea;
			padding: 20px 10px;
		}
			#comments .comment-list .comment .comment-body {
				color: black;
				font-size: 13px;
				position: relative;
			}
				#comments .comment-list .comment .comment-body p {
					margin: 5px 0 7px 0;
					overflow: hidden;
					padding: 0;
				}
			#comments .comment-list .comment .comment-author .avatar {
				float: left;
				height: 42px;
				margin-bottom: 10px;
				margin-right: 15px;
				width: 42px;
			}
			#comments .comment-list .comment .comment-author .fn {
				color: black;
				font-size: 13px;
				font-style: normal;
				font-weight: bold;
			}
			#comments .comment-list .comment .comment-author .says {
				display: none;
			}

			#comments .comment-list .comment .comment-meta {
				position: absolute;
				right: 0;
				top: 0;
			}
			#comments .comment-list .comment .reply {
				margin-left: 57px;
			}
			#comments .comment-list .comment .comment-meta a,
			#comments .comment-list .comment .reply a {
				color: #808080;
				font-size: 11px;
			}
				#comments .comment-list:hover .comment .comment-meta a,
				#comments .comment-list:hover .comment .reply a {
					color: #333;
				}
			#comments .comment-list .comment .reply .safe-comments-report-link:last-of-type {
				display: none;
			}
	#comments .comment-list .children {
		margin-left: 20px;
		margin-top: 20px;
	}
		#comments .comment-list .children .comment {
			border-top: none;
			padding-right: 0;
			padding-top: 0;
		}

	#comments #reply-title a {
		color: black;
		font-size: 13px;
		padding: 0 5px;
	}
		#comments #reply-title small a {
			font-weight: normal;
		}
	



</style>

<div class="commenting-container">
	<a name="comments" class="comments-location-beacon"></a>
	<section id="story-comments" class="column-item">

		<div id="comments" class="comments-area">

			
							
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/02/05/george-herbert-west-bridgewater-joy-magical-clown-retires/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=162246121&#038;postid=1041087&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.1.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=ecfee1957d9e7a66cc3f4fdf6fe2bad9016fabb0#parent=https%3A%2F%2Fboston.cbslocal.com%2F2020%2F02%2F05%2Fgeorge-herbert-west-bridgewater-joy-magical-clown-retires%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

					
		</div>

	</section>
</div>
<div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="http://www.facebook.com/CBSBoston" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/wbz" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a><a href="https://www.youtube.com/cbsboston" target="_blank" title="youtube_url" class="cbs-thumbnail-link youtube_url" ><div class="title-wrapper"><strong class="title">youtube_url</strong></div></a><a href="https://www.instagram.com/wbztv/" target="_blank" title="instagram_url" class="cbs-thumbnail-link instagram_url" ><div class="title-wrapper"><strong class="title">instagram_url</strong></div></a><a href="https://www.reddit.com/user/wbz-tv" target="_blank" title="reddit_url" class="cbs-thumbnail-link reddit_url" ><div class="title-wrapper"><strong class="title">reddit_url</strong></div></a><a href="https://www.linkedin.com/company/cbs-boston-local-digital-media/" target="_blank" title="linkedin_url" class="cbs-thumbnail-link linkedin_url" ><div class="title-wrapper"><strong class="title">linkedin_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_cbs_newsletter_widget"><h3 class="title">Our | Newsletter</h3><div class="widget-content-wrapper"><iframe id="newsletter-widget-iframe" width="300" src="https://bh-ems-static-content.s3.amazonaws.com/cbsi/2706/cbs_local_form_f.html?market=boston"></iframe></div></div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://boston.cbslocal.com/2020/01/28/massachusetts-china-indictments-charles-lieber-yanqing-ye-zaosong-zheng/" title="Harvard Professor, BU Researcher Among 3 Charged With Illegal Ties To China" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/01/lieber.jpg?resize=55%2C55&#038;ssl=1" alt="Harvard Professor, BU Researcher Among 3 Charged With Illegal Ties To China" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://boston.cbslocal.com/2020/01/28/massachusetts-china-indictments-charles-lieber-yanqing-ye-zaosong-zheng/" title="Harvard Professor, BU Researcher Among 3 Charged With Illegal Ties To China" class="bump-view" data-bump-view="tp">Harvard Professor, BU Researcher Among 3 Charged With Illegal Ties To China</a>
							</div>
													</li>
										<li>
						<a href="https://boston.cbslocal.com/2020/02/03/february-wintry-mix-forecast-jetstream-snow/" title="Burst Of Snow Expected For Early Thursday Morning Commute" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/dc.jpg?resize=55%2C55&#038;ssl=1" alt="Burst Of Snow Expected For Early Thursday Morning Commute" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://boston.cbslocal.com/2020/02/03/february-wintry-mix-forecast-jetstream-snow/" title="Burst Of Snow Expected For Early Thursday Morning Commute" class="bump-view" data-bump-view="tp">Burst Of Snow Expected For Early Thursday Morning Commute</a>
							</div>
													</li>
										<li>
						<a href="https://boston.cbslocal.com/2020/02/04/messy-thursday-snow-storm-rain-new-england/" title="Snow, Rain, Sleet, Ice Mix Will Make Mess Of Thursday Morning Commute" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/amcommute.jpg?resize=55%2C55&#038;ssl=1" alt="Snow, Rain, Sleet, Ice Mix Will Make Mess Of Thursday Morning Commute" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://boston.cbslocal.com/2020/02/04/messy-thursday-snow-storm-rain-new-england/" title="Snow, Rain, Sleet, Ice Mix Will Make Mess Of Thursday Morning Commute" class="bump-view" data-bump-view="tp">Snow, Rain, Sleet, Ice Mix Will Make Mess Of Thursday Morning Commute</a>
							</div>
													</li>
										<li>
						<a href="https://boston.cbslocal.com/2020/02/04/new-hampshire-primary-tracking-poll-pete-buttigieg-bernie-sanders/" title="Exclusive New Hampshire Primary Poll: Pete Buttigieg Gains, Bernie Sanders Leads" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/poll-1.jpg?resize=55%2C55&#038;ssl=1" alt="Exclusive New Hampshire Primary Poll: Pete Buttigieg Gains, Bernie Sanders Leads" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://boston.cbslocal.com/2020/02/04/new-hampshire-primary-tracking-poll-pete-buttigieg-bernie-sanders/" title="Exclusive New Hampshire Primary Poll: Pete Buttigieg Gains, Bernie Sanders Leads" class="bump-view" data-bump-view="tp">Exclusive New Hampshire Primary Poll: Pete Buttigieg Gains, Bernie Sanders Leads</a>
							</div>
													</li>
										<li>
						<a href="https://boston.cbslocal.com/2020/02/04/pfas-drinking-water-braintree-holbrook-randolph/" title="Potentially Dangerous Chemicals Found In Braintree, Holbrook And Randolph Drinking Water" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/braintree.jpg?resize=55%2C55&#038;ssl=1" alt="Potentially Dangerous Chemicals Found In Braintree, Holbrook And Randolph Drinking Water" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://boston.cbslocal.com/2020/02/04/pfas-drinking-water-braintree-holbrook-randolph/" title="Potentially Dangerous Chemicals Found In Braintree, Holbrook And Randolph Drinking Water" class="bump-view" data-bump-view="tp">Potentially Dangerous Chemicals Found In Braintree, Holbrook And Randolph Drinking Water</a>
							</div>
													</li>
										<li>
						<a href="https://boston.cbslocal.com/2020/02/04/red-sox-trade-mookie-betts-david-price-dodgers/" title="Red Sox Trade Mookie Betts, David Price To Dodgers" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/betts.jpg?resize=55%2C55&#038;ssl=1" alt="Red Sox Trade Mookie Betts, David Price To Dodgers" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://boston.cbslocal.com/2020/02/04/red-sox-trade-mookie-betts-david-price-dodgers/" title="Red Sox Trade Mookie Betts, David Price To Dodgers" class="bump-view" data-bump-view="tp">Red Sox Trade Mookie Betts, David Price To Dodgers</a>
							</div>
													</li>
										<li>
						<a href="https://boston.cbslocal.com/2020/02/04/mookie-betts-red-sox-trade-rumors-dodgers-padres-no-rush-imminent-mlb/" title="Report: Red Sox In No Rush To Complete Mookie Betts Trade" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/boston.cbslocal.com/wp-content/uploads/sites/3859903/2018/10/betts2.jpg?resize=55%2C55&#038;ssl=1" alt="Report: Red Sox In No Rush To Complete Mookie Betts Trade" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://boston.cbslocal.com/2020/02/04/mookie-betts-red-sox-trade-rumors-dodgers-padres-no-rush-imminent-mlb/" title="Report: Red Sox In No Rush To Complete Mookie Betts Trade" class="bump-view" data-bump-view="tp">Report: Red Sox In No Rush To Complete Mookie Betts Trade</a>
							</div>
													</li>
										<li>
						<a href="https://boston.cbslocal.com/2020/02/03/salisbury-waitress-5000-tip-ernie-boch-jr-challenge-donnie-wahlberg/" title="Ernie Boch Jr. Surprises Waitress With $5,000 Tip" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/02/tip.jpg?resize=55%2C55&#038;ssl=1" alt="Ernie Boch Jr. Surprises Waitress With $5,000 Tip" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://boston.cbslocal.com/2020/02/03/salisbury-waitress-5000-tip-ernie-boch-jr-challenge-donnie-wahlberg/" title="Ernie Boch Jr. Surprises Waitress With $5,000 Tip" class="bump-view" data-bump-view="tp">Ernie Boch Jr. Surprises Waitress With $5,000 Tip</a>
							</div>
													</li>
										<li>
						<a href="https://boston.cbslocal.com/2020/02/04/macys-stores-closing/" title="Macy&#039;s Will Close 125 Stores In The Next 3 Years" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/boston.cbslocal.com/wp-content/uploads/sites/3859903/2020/01/macys-logo.jpg?resize=55%2C55&#038;ssl=1" alt="Macy&#039;s Will Close 125 Stores In The Next 3 Years" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://boston.cbslocal.com/2020/02/04/macys-stores-closing/" title="Macy&#039;s Will Close 125 Stores In The Next 3 Years" class="bump-view" data-bump-view="tp">Macy&#039;s Will Close 125 Stores In The Next 3 Years</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://boston.cbslocal.com" class="logo"><img src="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2017/10/boston.png" alt="CBS Boston" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="http://www.facebook.com/CBSBoston" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/wbz" class="twitter" target="_blank">Twitter</a><a href="https://www.youtube.com/cbsboston" class="youtube" target="_blank">YouTube</a><a href="https://www.instagram.com/wbztv/" class="instagram" target="_blank">Instagram</a><a href="https://www.reddit.com/user/wbz-tv" class="reddit" target="_blank">Reddit</a><a href="https://www.linkedin.com/company/cbs-boston-local-digital-media/" class="linkedin" target="_blank">LinkedIn</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/category/news/local/" title="Boston News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Boston News</strong></div></a><a href="https://boston.cbslocal.com/category/politics/" title="Politics" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Politics</strong></div></a><a href="https://boston.cbslocal.com/category/news/business/" title="Business" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Business</strong></div></a><a href="https://boston.cbslocal.com/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://boston.cbslocal.com/category/weather/" title="Weather" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><a href="https://boston.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/category/sports/bruins/" title="Bruins" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Bruins</strong></div></a><a href="https://boston.cbslocal.com/category/sports/celtics/" title="Celtics" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Celtics</strong></div></a><a href="https://boston.cbslocal.com/category/sports/patriots/" title="Patriots" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Patriots</strong></div></a><a href="https://boston.cbslocal.com/category/sports/red-sox/" title="Red Sox" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Red Sox</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-2" >
		<header class="column-header">
				<h4 class="title">Other</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/category/bostons-best/" title="Boston&#039;s Best" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Boston&#039;s Best</strong></div></a><a href="https://boston.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="https://boston.cbslocal.com/closings/" title="Massachusetts School Closings" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Massachusetts School Closings</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-3" >
		<header class="column-header">
				<h4 class="title">Connect</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/station/wbz-tv/" title="Social" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Social</strong></div></a><a href="http://apps.cbslocal.com/" title="Download Our App" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Download Our App</strong></div></a><a href="http://apps.cbslocal.com/weather/boston/" title="Weather App" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Weather App</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-4" >
		<header class="column-header">
				<h4 class="title">Contacts &amp; Station Info</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/station/wbz-tv/" title="WBZ-TV" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">WBZ-TV</strong></div></a><a href="https://boston.cbslocal.com/station/tv38/" title="myTV38" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">myTV38</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-5" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://boston.cbslocal.com/learn-about-us/" title="About Us" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">About Us</strong></div></a><a href="https://boston.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://privacy.cbs/#onlinead" title="Ad Choices" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Ad Choices</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://boston.cbslocal.com" class="logo"><img src="https://boston.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Boston" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2020 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=boston.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://policies.cbslocal.com/privacy/current.html#video-services" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-285543" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-285543"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-285544" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-285544"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-1032211" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1032211"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-1032212" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1032212"><a href="https://ca.privacy.cbs/donotsell">California Do Not Sell My Info</a></li>
<li id="menu-item-652007" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-652007"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-983213" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-983213"><a href="https://publicfiles.fcc.gov/tv-profile/wbz-tv">Public File for WBZ-TV / WBZ</a></li>
<li id="menu-item-983212" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-983212"><a href="https://publicfiles.fcc.gov/tv-profile/wsbk-tv">Public File for WSBK-TV / myTV38</a></li>
<li id="menu-item-983211" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-983211"><a href="https://policies.cbslocal.com/fcc/contactusfcc.html">Public Inspection File Help</a></li>
<li id="menu-item-984425" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-984425"><a href="https://boston.cbslocal.com/wp-content/uploads/sites/3859903/2019/11/WBZ-WSBK-Public-File-12-18-to-11-19-NO-NAMES-BOSTVHR1.pdf">EEO Report</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='screen-css-0' href='https://boston.cbslocal.com/_static/??-eJylj1EKgCAQRC+UbX0k9hGdxXQpYdVoN6TbJ9EJ6m+YNzwYKLtyOQkmAdkwIoNbWFF2liAkR6evFcYFfSX8RlXQ1vWhSvArSltBA99MTMHj8ceQRXay1z8JBX5uzHHqBz0abUzf3caaaUI=' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://boston.cbslocal.com/_static/??-eJx9jEEOwjAMBD9EawpqOSHeUhyrNXKcEDuq+D3h1J647e6sBrbcYVIndfCVIhng0zpJOAuwotTQpte7UvmA8LK6CQcqx9xH1h7NTvBPlqUurAYxhSqN5Lm4UmkX28tP84j3YZyul9t0HsYvP1k7lA==' type='text/css' media='all' />
<script>
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
</script>
<script type='text/javascript' src='https://boston.cbslocal.com/_static/??-eJyVjs0KwjAQhF/IdA1FexIfRfKzlk2zSTAbSn16A15y1OMw33wM7EW5nASTADdVYlspVQgoxbgNHpQc2EbRw9M4tDlvCtmin5jSFOoJft7LTiL4UkKMkRL+b4jmfShis2Kv6xhHV+dj81+kx/HtnW/6slwXrc/zHD5U9lv/'></script>
<script src='https://widgets.media.weather.com/wxwidget.loader.js?cid=934888385&#038;ver=1.1'></script>
<script type='text/javascript' src='https://boston.cbslocal.com/_static/??-eJytzDEOwjAMheELkVoQIbogjoLSxLQJdhJqR6i3JwMDAwMD26+npw+e1fiSFbOCLsgo4CcxVLwjiNlTC31Kj4brBhTnRYViwPWzB455SLKDnyzkCUMn32X+YRTVSm77znAzldocs4C7R2FUuHYJbmXl/r3weX88jdba8WDTC90uZMU='></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=162246121&postid=1041087&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.1.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=ecfee1957d9e7a66cc3f4fdf6fe2bad9016fabb0#parent=https%3A%2F%2Fboston.cbslocal.com%2F2020%2F02%2F05%2Fgeorge-herbert-west-bridgewater-joy-magical-clown-retires%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=162246121&postid=1041087&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.1.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=ecfee1957d9e7a66cc3f4fdf6fe2bad9016fabb0#parent=https%3A%2F%2Fboston.cbslocal.com%2F2020%2F02%2F05%2Fgeorge-herbert-west-bridgewater-joy-magical-clown-retires%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202006.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.1.1',blog:'162246121',post:'1041087',tz:'-5',srv:'boston.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246121', '1041087' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>